This incident is resolved for users of Chrome and Microsoft Edge. We are still actively working on providing the best experience possible with Google Slides but as of now users should be able to insert slides again on both platforms.
Posted Apr 10, 2025 - 16:08 PDT
Update
We have resolved the Google Slides activity insertion issue for the Google Chrome Extension after our submission was approved. We are still pending approval for our Microsoft Edge extension update. We will provide further updates as soon as we can.
Posted Apr 10, 2025 - 14:51 PDT
Update
We have resolved the Google Slides activity insertion issue for the Google Chrome Extension after our submission was approved. We are still pending approval for our Microsoft Edge extension update. We will provide further updates as soon as we can.
Posted Apr 09, 2025 - 08:16 PDT
Update
We have resubmitted a fix to the Microsoft Edge Extension store. Our extension is still pending approval for the Chrome Web Store. We will provide further updates as soon as we can.
Posted Apr 08, 2025 - 09:28 PDT
Update
We have resubmitted a fix to the Google Chrome Web Extension store. We will provide further updates as soon as we can.
Posted Apr 07, 2025 - 08:28 PDT
Update
We are actively iterating on a fix to update the insert activity flow to the Google Chrome and Microsoft Edge Extension stores. This is currently our top priority, and we will update this to resolved once approved.
Posted Apr 07, 2025 - 07:43 PDT
Monitoring
We have submitted a fix to update the insert activity flow to the Google Chrome and Microsoft Edge Extension stores. We will update this to resolved once those have been approved.
Posted Apr 04, 2025 - 14:58 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 04, 2025 - 13:15 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 04, 2025 - 09:09 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 03, 2025 - 16:00 PDT
Update
We are continuing to work on a fix for the Google Slides insertion issue.
Posted Apr 03, 2025 - 13:16 PDT
Identified
We have identified the root cause of the Google Slides insertion issue and are investigating a fix
Posted Apr 03, 2025 - 11:15 PDT
Investigating
In our Google Slides browser extension some users are unable to insert Poll Everywhere slides. We are currently investigating