Investigating reports of users being unable to process payments

Incident Report for Poll Everywhere

Resolved

We have resolved the issue with payments.
Posted Apr 25, 2025 - 07:32 PDT

Identified

The issue has been identified and a fix is currently being implemented
Posted Apr 25, 2025 - 07:15 PDT

Investigating

We received reports that some users are unable to process payments and are currently investigating this issue.
Posted Apr 25, 2025 - 06:35 PDT
This incident affected: PollEverywhere.com.