Activities not loading
Incident Report for Poll Everywhere
Resolved
Activities are now loading properly, this issue is now resolved
Posted Aug 31, 2023 - 17:24 PDT
Identified
We have identified a fix to activities not loading and are actively mitigating
Posted Aug 31, 2023 - 17:18 PDT
Investigating
All Poll Everywhere activities are not loading, we are currently investigating the issue. We will post an update in one hour.
Posted Aug 31, 2023 - 17:15 PDT
This incident affected: PollEverywhere.com, PollEv.com, and Apps and integrations.