We have identified an issue where Poll Everywhere activities will not insert in Google Slides

Incident Report for Poll Everywhere

Monitoring

We have submitted a new version of the Poll Everywhere for Google Slides app to the Google extension store. We will update this status to Resolved once v1.20.4 has been approved and is available.
Posted Jan 09, 2026 - 08:43 PST

Identified

We have identified the problem that is preventing Google Slides insertion. We are working on a new release that will fix the problem.
Posted Jan 09, 2026 - 07:45 PST
This incident affects: Apps and integrations.