Temporary outage on PollEv.com
Incident Report for Poll Everywhere
Resolved
We've resolved the issue, and are continuing to investigate the long-term cause.
Posted Jun 17, 2024 - 13:49 PDT
Investigating
We're investigating a temporary outage on PollEv.com
Posted Jun 17, 2024 - 13:41 PDT
This incident affected: PollEverywhere.com and PollEv.com.