Newly created accounts run into "You are not authorized to perform this action" when trying to create new Polls.

Incident Report for Poll Everywhere

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 08:48 PDT

Identified

We have identified the root cause and are working on a fix.
Posted Jul 17, 2025 - 20:48 PDT

Investigating

We are currently investigating the issue
Posted Jul 17, 2025 - 11:06 PDT
This incident affected: pe.app.