Australia 2 phone number down
Incident Report for Poll Everywhere
Resolved
This incident has been resolved.
Posted Oct 28, 2024 - 07:43 PDT
Investigating
We are currently investigating an issue with our 'Australia 2'(+61 480 025 509 ) phone number not receiving text messages for poll responses. You can use a different phone number to participate from our International text messaging page, or use web responses while we work to resolve the issue.
Posted Oct 24, 2024 - 07:58 PDT
This incident affected: PollEverywhere.com.