Errors with login

Incident Report for Poll Everywhere

Resolved

We resolved a misconfiguration issue that led to the login service being temporarily unavailable. Please contact Poll Everywhere support for more information related to this incident.
Posted Sep 03, 2025 - 08:16 PDT

Monitoring

We believe the incident is resolved, but we are continuing to monitor and investigate.
Posted Sep 03, 2025 - 07:38 PDT

Investigating

We are currently investigating an issue where users are unable to login on the Poll Everywhere website and apps.
Posted Sep 03, 2025 - 07:30 PDT
This incident affected: PollEverywhere.com, PollEv.com, and Apps and integrations.