Outage in 2.0 (pe.app) and degraded performance in 1.0 (polleverywhere.com)

Incident Report for Poll Everywhere

Postmortem

During the AWS us-east-1 outage that occurred on October 19 and 20th of 2025, Poll Everywhere experienced degraded services, particularly with our 2.0 product at pe.app, and some internal systems. Our third-party service providers, Amazon Web Services and WorkOS, have published technical write ups related to the incident. We have read these reports and understand the impact that the AWS us-east-1 outage had on our services and how we can improve our response to these incidents in the future.

For more technical details, please see:

Immediately following the outages that impacted Poll Everywhere, we contacted our partner vendors, including WorkOS, to understand their response to our inquiry and the greater outage. In-particular, we understand that WorkOS will be conducting multi-region deployments of their critical services in a hot standby configuration by the end of Q1 2026, which will eliminate this type of failure as a possibility in the future.

With the exception of WorkOS in 2.0, our core product and services remained online with only minor disruption to some SMS providers. As a result, we do not have other remediation work planned as a result of this outage. We will continue to monitor WorkOS and work with the WorkOS team to provide feedback and dialog as they work to implement hot standby support and multi-region deployments over the coming months.

Posted Oct 26, 2025 - 23:35 PDT

Resolved

This incident has been resolved. This incident was caused by the failure of an upstream provider, Amazon Web Services (us-east-1). When AWS us-east-1 failed, a cascade failure occurred with several of our service providers. Poll Everywhere is hosted in Amazon Web Services (us-east-2) and although some of our third-party service providers, including Canvas, Talkdesk, Slack, Zendesk, Twilio, and WorkOS failed, our core platform on PollEverywhere.com remained fully functional.

With respect to Poll Everywhere 2.0 at pe.app, we are working with our upstream provider, WorkOS, to determine solutions to future AWS outages.

Please reach out to us at support@polleverywhere.com if you are continuing to experience issues with any of our services.
Posted Oct 20, 2025 - 04:45 PDT

Monitoring

Services look to be restored by our providers, we are continuing to monitor
Posted Oct 20, 2025 - 02:58 PDT

Update

Various components of our service are recovering as a result of the Amazon Web Services US-West-1 outage that occurred earlier today. Some services are partially recovered or are performing as expected on an intermittent basis right now. In-particular, sign-in to pe.app via WorkOS and directory sync services have been partially restored. We continue to be unable to accept inbound support phone calls, and some SMS numbers provided by Twilio remain inoperable. Additionally, as services are restored in phases, we expect there to be small amounts of errors in the platforms as the cascade failure is recovered from.

Currently, users with existing sessions on pe.app and polleverywhere.com, as well as responses on pollev.com remain fully functional.
Posted Oct 20, 2025 - 02:51 PDT

Update

Ongoing incident with various providers. We've identified further systems affected.

Significantly affecting authentication in 2.0 (pe.app).

Degraded performance in 1.0 (polleverywhere.com) affecting directory sync and SMS.

Additionally our support systems for email and phone support are experiencing outages.

See:
- https://status.workos.com/incidents/b178c1kxt0g3
- https://health.aws.amazon.com/health/status (various services)
- https://status.zendesk.com/ (email support)
- https://status.talkdesk.com/ (phone support)
Posted Oct 20, 2025 - 02:16 PDT

Update

We are continuing to monitor this issue
Posted Oct 20, 2025 - 01:52 PDT

Identified

Ongoing incident with various providers.

Significantly affecting authentication in 2.0 (pe.app).

Degraded performance in 1.0 (polleverywhere.com) affecting directory sync and SMS.

See:
- https://status.workos.com/incidents/b178c1kxt0g3
- https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 00:28 PDT
This incident affected: PollEverywhere.com, pe.app and Third-party service providers (WorkOS AuthKit, WorkOS SSO, WorkOS Admin Portal).