Poll Everywhere 2.0 504 Errors

Incident Report for Poll Everywhere

Resolved

The issue has been resolved.

This was caused due to an incident with our authentication provider. Updates on this incident can be found on their status page.
https://status.workos.com/incidents/phs2prf38d75
Posted Sep 18, 2026 - 16:07 PDT

Update

We are continuing to investigate this issue.
Posted Sep 18, 2026 - 15:49 PDT

Investigating

We are seeing 504 gateway timeouts across the site as well as integrations.
Posted Sep 18, 2026 - 15:46 PDT
This incident affected: pe.app.