Polleverywhere.com homepage sometimes not loading
Incident Report for Poll Everywhere
Resolved
We've completed remediation work on a long-term resolution to this issue, which will prevent recurrence of this type of failure in the future.
Posted Feb 15, 2024 - 10:11 PST
Monitoring
We believe the incident that has caused www.polleverywhere.com to not connect is resolved. We are continuing to monitor the issue.
Posted Feb 14, 2024 - 09:44 PST
Update
We are continuing to investigate this issue.
Posted Feb 14, 2024 - 09:20 PST
Investigating
We are currently investigating an issue where www.polleverywhere.com is sometimes not loading properly. If you need to access activities, you can navigate directly to www.polleverywhere.com/activities
Posted Feb 14, 2024 - 09:19 PST
This incident affected: PollEverywhere.com.