Roster sync unavailable

Incident Report for Poll Everywhere

Resolved

We have implemented a fix for the issue, and roster sync should be performing as normal now. Please let us know if you experience any more problems with this part of the service at support@polleverywhere.com.
Posted Jun 12, 2024 - 15:03 PDT

Investigating

We're investigating an issue where the ability to sync rosters is unavailable on PollEverywhere.com. Specifically, a "Content missing" page is displayed, instead of the roster sync dashboard.
Posted Jun 12, 2024 - 12:41 PDT
This incident affected: PollEverywhere.com.