Intermittent errors logging in

Incident Report for Poll Everywhere

Resolved

This issue, which was the result of an issue with WorkOS, our third-party service provider, has been resolved.
Posted Jul 16, 2026 - 06:24 PDT

Monitoring

Things look to be improving, continue to check https://status.workos.com/incidents/b52fkqjzcl20 for details and updates
Posted Jul 16, 2026 - 03:18 PDT

Identified

Follow https://status.workos.com/incidents/b52fkqjzcl20 for details and updates
Posted Jul 16, 2026 - 01:32 PDT

Investigating

We are currently investigating higher error rates when trying to authenticate
Posted Jul 16, 2026 - 01:23 PDT
This incident affected: pe.app.