Poll Everywhere 2.0 billing links go to "stripe.com"

Incident Report for Poll Everywhere

Resolved

This has been resolved
Posted Jan 26, 2026 - 13:05 PST

Identified

We've identified an issue where some billing emails and links on Poll Everywhere 2.0 go to "checkout.stripe.com", "buy.stripe.com", or "billing.stripe.com", or Stripe, our payment processor, instead of billing.pe.app. We're working on resolving the issue. In the interim, these links are safe. If you are curious about the authenticity of any email or link, please contact support@polleverywhere.com.
Posted Jan 26, 2026 - 10:09 PST
This incident affected: pe.app and Third-party service providers (Stripe API).