Users getting blocked on 1.0/2.0 site picker

Incident Report for Poll Everywhere

Resolved

This incident has been resolved
Posted Aug 11, 2025 - 07:54 PDT

Update

We are continuing to investigate this issue. A workaround until a fix is released is to access the website via the URL www.polleverywhere.com/home.
Posted Aug 11, 2025 - 07:26 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 11, 2025 - 07:13 PDT

Investigating

We are investigating an issue where logging in does not redirect the user to the correct website's homepage when accessing polleverywhere.com. We apologize for any inconvenience.
Posted Aug 11, 2025 - 06:51 PDT
This incident affected: PollEverywhere.com.