Unable to contact customer support by phone

Incident Report for Poll Everywhere

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 11:15 PDT

Update

Talkdesk has resolved the issue, and we are now receiving customer service calls again.
Posted Mar 31, 2025 - 11:14 PDT

Monitoring

We are currently seeing an issue with Talkdesk where customer service phone calls are not being routed to our agents.

If you need to contact customer support, please use our email form here: https://www.polleverywhere.com/contact/support

You can find out more on Talkdesk's status page: https://status.talkdesk.com/
Posted Mar 31, 2025 - 10:16 PDT
This incident affected: Third-party service providers (Talkdesk).