pe.app signin and AI poll creation is down

Incident Report for Poll Everywhere

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 13:21 PDT

Update

We're continuing to monitor the issue. WorkOS now reports a major outage across all platforms. WorkOS is a decedent third-party service provider from Google Cloud. We do not have an estimate on service restoration for the affected services, but we are continuing to monitor the situation.
Posted Jun 12, 2025 - 11:49 PDT

Investigating

A third-party service provider, Google Cloud, is experiencing difficulties. During this time, AI poll creation features on PollEverywhere.com are unavailable, pe.app sign-in is unavailable, and WorkOS directory sync (SCIM) is unavailable. We are monitoring the service for restoration and will provide an update when services are restored.
Posted Jun 12, 2025 - 11:42 PDT
This incident affected: PollEverywhere.com, pe.app and Third-party service providers (WorkOS AuthKit, WorkOS SSO).