Unable to use AI to create polls in 2.0

Incident Report for Poll Everywhere

Resolved

We've identified and resolved the issue affecting an external service provider and AI in the Poll Everywhere 2.0 platform.
Posted Apr 28, 2025 - 07:16 PDT

Investigating

We're experiencing a problem with an external service provider when creating polls using AI in the Poll Everywhere 2.0 platform.
Posted Apr 28, 2025 - 07:04 PDT
This incident affected: pe.app.