Slow job performance with some tasks

Incident Report for Poll Everywhere

Resolved

We've changed the self-healing and autoscaling system to be more tolerant of faults at the times that the system has increased load. We've confirmed that the system is functioning normally as of right now and believe the problem to be resolved in the long term.
Posted Jun 25, 2026 - 03:45 PDT

Identified

We've identified the autoscaling performance issue and are working on implementing a long-term fix.
Posted Jun 25, 2026 - 02:47 PDT

Update

The system has self-healed and brought the delay down to ~5 minutes and dropping. We are continuing to investigate.
Posted Jun 25, 2026 - 02:23 PDT

Investigating

Some tasks are currently delayed (such as deleting polls) in 1.0.
Posted Jun 25, 2026 - 02:19 PDT
This incident affected: PollEverywhere.com.