Sign in not working at Polleverywhere.com

Incident Report for Poll Everywhere

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 08:40 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 04, 2025 - 08:09 PDT

Update

We are continuing to work on the fix.
Posted Aug 04, 2025 - 08:05 PDT

Identified

We are currently working on the issue.
Posted Aug 04, 2025 - 08:03 PDT
This incident affected: PollEverywhere.com.