Service Unavailable (Poll Everywhere 1.0)

Incident Report for Poll Everywhere

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 07:37 PDT

Investigating

We are currently investigating the issue
Posted Sep 05, 2025 - 07:11 PDT
This incident affected: PollEverywhere.com, PollEv.com, and Apps and integrations.