Unable to log into Poll Everywhere in Google Slides

Incident Report for Poll Everywhere

Resolved

An update to Google Chrome has possibly turned off 3rd party cookies by default. The Poll Everywhere Google Slides plugin requires 3rd party cookies to present Poll Everywhere Activities. Enable 3rd party cookies to restore this functionality.
Posted Jul 31, 2025 - 12:17 PDT

Investigating

We are currently investigating an issue with our Google Slides integration and users being unable to login to Polleverywhere.
Posted Jul 31, 2025 - 12:06 PDT
This incident affected: Apps and integrations.