Invites and Email Codes for authentication are down

Incident Report for Poll Everywhere

Resolved

This incident has been resolved.

If you sent invites during this time and invites were not received, please resend invitations.
Posted Aug 25, 2026 - 14:18 PDT

Identified

We've identified the issue and are working to resolve this.
Posted Aug 25, 2026 - 14:15 PDT
This incident affected: pe.app.