We continue to wait for approval on both our Google Chrome and Microsoft Edge extension updates. We will provide further status updates as soon as we can, and we apologize for this inconvenience.
Posted Apr 23, 2025 - 09:15 PDT
Update
We have submitted a fix to the Microsoft Edge store. We're now waiting for approval for both Google and Microsoft web stores. We will provide further updates as soon as we can.
Posted Apr 22, 2025 - 06:46 PDT
Monitoring
We have submitted a fix to the Google Web Store and we're waiting for approval. We will submit a fix to the Microsoft Edge Store shortly.
Posted Apr 21, 2025 - 11:40 PDT
Identified
We have identified the root cause of the issue. Google has recently updated their Google Slides presentations in a way that requires us to make adjustments to the way our Slides extension works. A fix is currently being worked on by our engineering team, we apologize for the inconvenience.