Some users are experiencing service unavailable on Poll Everywhere(resolved)
Incident Report for Poll Everywhere
Resolved
The incident is resolved, and we have identified the root cause and implemented a step to prevent a future occurrence.
Posted Feb 26, 2024 - 08:30 PST
Monitoring
We have restored service and we will continue to investigate and monitor.
Posted Feb 26, 2024 - 08:23 PST
Investigating
We are currently investigating this issue.
Posted Feb 26, 2024 - 08:19 PST
This incident affected: PollEverywhere.com and PollEv.com.