Poll Everywhere 1.0 Instability

Incident Report for Poll Everywhere

Resolved

A fix has been implemented.

This incident was caused by a framework upgrade causing database timeouts in requests. During this outage, activation, poll creation / editing, as well as several other core features experienced disruption due to database requests timing out.
Posted Apr 14, 2026 - 13:23 PDT

Investigating

We've observed a elevated number of error across the site. We are currently investigating a root cause.
Posted Apr 14, 2026 - 13:08 PDT
This incident affected: PollEverywhere.com.