Some users are unable to access account admin page in www.polleverywhere.com
Incident Report for Poll Everywhere
Resolved
The issue has been resolved. All users can access the account admin page at www.polleverywhere.com.
Posted Oct 11, 2024 - 12:57 PDT
Investigating
We are currently investigating an issue where some users are unable to access the account admin page.
Posted Oct 11, 2024 - 12:01 PDT
This incident affected: PollEverywhere.com.