Poll Everywhere 2.0 PowerPoint Integration is undergoing maintenance

Incident Report for Poll Everywhere

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 19:58 PDT

Monitoring

The Poll Everywhere 2.0 PowerPoint integration is being resubmitted to the Microsoft PowerPoint store. While this is happening, some users may experience an error that says "This add-in is being retired and will be un-available soon". This error should be resolved once Microsoft approves the re-submission.
Posted Jun 17, 2025 - 10:01 PDT
This incident affected: Apps and integrations.