PollEverywhere.com main site is down
Incident Report for Poll Everywhere
Resolved
We've resolved the situation where some pages displayed a "down for maintenance" page and will continue to monitor the situation to ensure that it remains stable.
Posted Nov 20, 2023 - 09:04 PST
Update
We've resolved the issue where PollEverywhere.com displayed a "down for maintenance" page on the main site. However, the same "down for maintenance" page will still be displayed when attempting to download apps or viewing other static content on the main site. The core service remains fully operational.

We will provide an update tomorrow, November 20th, 2023 on the restoration of other pages on PollEverywhere.com.
Posted Nov 19, 2023 - 17:29 PST
Investigating
We're identifying an issue where a "down for maintenance" page is displayed on PollEverywhere.com. PollEv.com activities are unaffected. As a workaround, you can login at https://id.polleverywhere.com/login and you can view your activities and perform tasks using https://polleverywhere.com/activities.
Posted Nov 19, 2023 - 16:45 PST
This incident affected: PollEverywhere.com.