Degraded performance

Incident Report for Poll Everywhere

Resolved

This incident has been resolved.
Posted May 29, 2025 - 13:44 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2025 - 20:49 PDT

Investigating

A small portion of requests are experiencing elevated errors, we're currently investigating.
Posted May 28, 2025 - 20:17 PDT
This incident affected: PollEverywhere.com, PollEv.com, and Apps and integrations.