User uploaded images not loading on Poll Everywhere 1.0

Incident Report for Poll Everywhere

Resolved

We have fixed the issue that was preventing user uploaded image from loading.
Posted Oct 10, 2025 - 09:39 PDT

Investigating

We are currently investigating an issuer where user uploaded image for polls are not appearing on 1.0. We are working to resolve that issue now.
Posted Oct 10, 2025 - 01:48 PDT
This incident affected: PollEverywhere.com.