Report generation is slow
Incident Report for Poll Everywhere
Resolved
We've identified and resolved the root cause that caused the delay with reports.
Posted Oct 24, 2023 - 15:50 PDT
Update
We've scaled up our background job processors and have improved the report generation time to approximately 15 minutes. We're working on getting this back to normal times.
Posted Oct 24, 2023 - 15:34 PDT
Investigating
We're investigating an issue where report generation is slow, taking up to 2 hours to generate or update reports.
Posted Oct 24, 2023 - 14:25 PDT
This incident affected: PollEverywhere.com.