pe.app is experiencing permissions issues

Incident Report for Poll Everywhere

Resolved

The issue loading polls on pe.app has been resolved. The issue started at 17:48 PDT on June 5th, 2025, and was resolved on 00:39 PDT on June 6th, 2025.
Posted Jun 06, 2025 - 00:42 PDT

Update

We're continuing to investigate the problem with pe.app.
Posted Jun 06, 2025 - 00:32 PDT

Investigating

We are currently investigating this issue, users may not be able to access their Polls or Questions.
Posted Jun 06, 2025 - 00:05 PDT
This incident affected: pe.app.