Elevated Errors
Incident Report for Poll Everywhere
Resolved
We are continuing to investigate an issue that occurred from approximately 10:41 to 10:55 PST.
Posted Jul 15, 2024 - 11:18 PDT
Investigating
We currently investigating an issue that may intermittent affect poll activation and other PE services.
Posted Jul 15, 2024 - 10:50 PDT
This incident affected: PollEverywhere.com, PollEv.com, and Apps and integrations.