Poll Activation Issues with Google Slides
Incident Report for Poll Everywhere
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 12:48 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 14, 2023 - 08:09 PDT
Investigating
We are currently investigating an incident where polls sometimes fail to activate while presenting with the Poll Everywhere for Google Slides app for Google Chrome. We're actively working on this issue and determining a root cause.
Posted Aug 09, 2023 - 12:46 PDT
This incident affected: Apps and integrations.