Issue with participant invitation password reset links
Incident Report for Poll Everywhere
Resolved
This incident has been resolved.
Posted Aug 24, 2023 - 10:22 PDT
Identified
We have noticed an issue where participants are unable to use the password reset link within participant invitation emails. We are working on addressing the issue now.

If you run into this issue, you can reset your password by using the 'Forgot Password' link on https://id.polleverywhere.com/login
Posted Aug 24, 2023 - 07:58 PDT
This incident affected: PollEv.com.