Users attempting to upgrade their plan on polleverywhere.com are being redirected to pe.app

Incident Report for Poll Everywhere

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 12:59 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 07, 2025 - 12:58 PDT

Identified

We have identified an issue where users attempting to upgrade their plans on polleverywhere.com are being redirected to pe.app. We are actively working on a fix and apologize for any inconvenience.
Posted Aug 07, 2025 - 09:54 PDT
This incident affected: PollEverywhere.com.