Support outage

Incident Report for Poll Everywhere

Resolved

Our third-party service provider has resolved the issue.
Posted Sep 08, 2026 - 09:36 PDT

Identified

Currently, our third-party service provider for email-based customer support, HubSpot, is experiencing an outage. See: https://status.hubspot.com/

We will update this notice when the issue contacting support is resolved.
Posted Sep 08, 2026 - 09:35 PDT