Continued intermittent pollev.com issues
Incident Report for Poll Everywhere
Resolved
The issue has been mitigated. We are continuing to investigate the root cause.
Posted Jun 10, 2024 - 01:53 PDT
Identified
The activity response pages at http://pollev.com are continuing to experience intermittent loading issues or errors. We are working on mitigating the issue.
Posted Jun 10, 2024 - 01:04 PDT
This incident affected: PollEv.com.